timewarrior: Patch for system include path

So that <glob.h> is found in Termux custom include dir.
This commit is contained in:
Fredrik Fornwall 2016-09-05 17:55:39 -04:00
parent 18bf425df5
commit eb81fe3346
2 changed files with 12 additions and 1 deletions

View File

@ -9,7 +9,9 @@ TERMUX_PKG_VERSION=1.0.0
TERMUX_PKG_SRCURL=http://taskwarrior.org/download/timew-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libandroid-glob"
LDFLAGS+=" -landroid-glob"
termux_step_pre_configure() {
LDFLAGS+=" -landroid-glob"
}
termux_step_configure () {
cd $TERMUX_PKG_BUILDDIR

View File

@ -0,0 +1,9 @@
diff -u -r ../timew-1.0.0/src/CMakeLists.txt ./src/CMakeLists.txt
--- ../timew-1.0.0/src/CMakeLists.txt 2016-08-17 17:23:15.000000000 -0400
+++ ./src/CMakeLists.txt 2016-09-05 17:53:00.643967527 -0400
@@ -1,4 +1,5 @@
cmake_minimum_required (VERSION 2.8)
+include_directories(SYSTEM "@TERMUX_PREFIX@/include")
include_directories (${CMAKE_SOURCE_DIR}
${CMAKE_SOURCE_DIR}/src
${CMAKE_SOURCE_DIR}/src/commands