new package: vtm

Requested in https://github.com/termux/termux-packages/issues/7490.
This commit is contained in:
Leonid Pliushch 2021-10-04 15:41:53 +03:00
parent 564f2c496d
commit ebb6b25420
No known key found for this signature in database
GPG Key ID: 45F2964132545795
3 changed files with 59 additions and 0 deletions

View File

@ -0,0 +1,25 @@
diff -uNr vtm-0.5.15/src/CMakeLists.txt vtm-0.5.15.mod/src/CMakeLists.txt
--- vtm-0.5.15/src/CMakeLists.txt 2021-08-04 21:50:44.000000000 +0000
+++ vtm-0.5.15.mod/src/CMakeLists.txt 2021-10-04 12:35:14.765769171 +0000
@@ -13,14 +13,6 @@
#set (CMAKE_EXE_LINKER_FLAGS "/MANIFEST:NO")
set (CMAKE_CXX_FLAGS "/DWIN32 /D_WINDOWS /W3 /GR /EHsc /bigobj")
-else ()
- if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
- #static linkage
- #set (CMAKE_CXX_FLAGS "-static-libstdc++ -static-libgcc -pthread -s")
- set (CMAKE_CXX_FLAGS "-pthread -s")
- else ()
- set (CMAKE_CXX_FLAGS "-pthread")
- endif ()
endif ()
add_executable (vtmd "vtmd.cpp")
@@ -29,4 +21,4 @@
if (NOT WIN32)
install (TARGETS vtmd DESTINATION bin)
install (TARGETS vtm DESTINATION bin)
-endif ()
\ No newline at end of file
+endif ()

15
packages/vtm/build.sh Normal file
View File

@ -0,0 +1,15 @@
TERMUX_PKG_HOMEPAGE=https://vtm.netxs.online/
TERMUX_PKG_DESCRIPTION="Terminal multiplexer with TUI window manager and multi-party session sharing"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.5.15
TERMUX_PKG_SRCURL=https://github.com/netxs-group/vtm/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=fa18ae2f1eee9615c6e0df5be4b248fb15268c5e7401380f129ccee8cb9254f0
TERMUX_PKG_DEPENDS="libandroid-spawn"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_pre_configure() {
TERMUX_PKG_SRCDIR+=/src
CXXFLAGS+=" -pthread"
LDFLAGS+=" -landroid-spawn"
}

View File

@ -0,0 +1,19 @@
diff -uNr vtm-0.5.15/src/netxs/os/system.hpp vtm-0.5.15.mod/src/netxs/os/system.hpp
--- vtm-0.5.15/src/netxs/os/system.hpp 2021-08-04 21:50:44.000000000 +0000
+++ vtm-0.5.15.mod/src/netxs/os/system.hpp 2021-10-04 12:37:37.069884293 +0000
@@ -81,7 +81,7 @@
#if defined(__linux__)
#include <sys/vt.h> // ::console_ioctl()
- #include <sys/kd.h> // ::console_ioctl()
+ #include <linux/kd.h> // ::console_ioctl()
#include <linux/keyboard.h> // ::keyb_ioctl()
#endif
#endif
@@ -2634,4 +2634,4 @@
};
}
-#endif // NETXS_SYSTEM_HPP
\ No newline at end of file
+#endif // NETXS_SYSTEM_HPP