new package: python-apt
This commit is contained in:
parent
d01cf13c36
commit
ec6de3b815
33
packages/python-apt/build.sh
Normal file
33
packages/python-apt/build.sh
Normal file
@ -0,0 +1,33 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://apt-team.pages.debian.net/python-apt/
|
||||
TERMUX_PKG_DESCRIPTION="Python bindings for APT"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=2.3.0
|
||||
TERMUX_PKG_SRCURL=https://ftp.debian.org/debian/pool/main/p/python-apt/python-apt_${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_SHA256=de4a284bc7a738793615631d451524f42404034f4d787953b7621b25bc29e474
|
||||
TERMUX_PKG_DEPENDS="apt, libc++, python"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
_PYTHON_VERSION=$(. $TERMUX_SCRIPTDIR/packages/python/build.sh; echo $_MAJOR_VERSION)
|
||||
|
||||
termux_step_pre_configure() {
|
||||
termux_setup_python_crossenv
|
||||
pushd $TERMUX_PYTHON_CROSSENV_SRCDIR
|
||||
_CROSSENV_PREFIX=$TERMUX_PKG_BUILDDIR/python-crossenv-prefix
|
||||
python${_PYTHON_VERSION} -m crossenv \
|
||||
$TERMUX_PREFIX/bin/python${_PYTHON_VERSION} \
|
||||
${_CROSSENV_PREFIX}
|
||||
popd
|
||||
. ${_CROSSENV_PREFIX}/bin/activate
|
||||
|
||||
pushd ${_CROSSENV_PREFIX}/build/lib/python${_PYTHON_VERSION}/site-packages
|
||||
patch --silent -p1 < $TERMUX_PKG_BUILDER_DIR/setuptools-44.1.1-no-bdist_wininst.diff || :
|
||||
popd
|
||||
|
||||
LDFLAGS+=" -lpython${_PYTHON_VERSION}"
|
||||
}
|
||||
|
||||
termux_step_make_install() {
|
||||
DEBVER=$TERMUX_PKG_VERSION \
|
||||
python setup.py install --force --prefix $TERMUX_PREFIX
|
||||
}
|
35
packages/python-apt/setuptools-44.1.1-no-bdist_wininst.diff
Normal file
35
packages/python-apt/setuptools-44.1.1-no-bdist_wininst.diff
Normal file
@ -0,0 +1,35 @@
|
||||
Copyright (C) 2016 Jason R Coombs <jaraco@jaraco.com>
|
||||
|
||||
Permission is hereby granted, free of charge, to any person obtaining a copy of
|
||||
this software and associated documentation files (the "Software"), to deal in
|
||||
the Software without restriction, including without limitation the rights to
|
||||
use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
|
||||
of the Software, and to permit persons to whom the Software is furnished to do
|
||||
so, subject to the following conditions:
|
||||
|
||||
The above copyright notice and this permission notice shall be included in all
|
||||
copies or substantial portions of the Software.
|
||||
|
||||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
|
||||
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
|
||||
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
|
||||
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
|
||||
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
|
||||
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
|
||||
SOFTWARE.
|
||||
|
||||
--- a/setuptools/command/install_scripts.py
|
||||
+++ b/setuptools/command/install_scripts.py
|
||||
@@ -32,12 +32,7 @@
|
||||
)
|
||||
bs_cmd = self.get_finalized_command('build_scripts')
|
||||
exec_param = getattr(bs_cmd, 'executable', None)
|
||||
- bw_cmd = self.get_finalized_command("bdist_wininst")
|
||||
- is_wininst = getattr(bw_cmd, '_is_running', False)
|
||||
writer = ei.ScriptWriter
|
||||
- if is_wininst:
|
||||
- exec_param = "python.exe"
|
||||
- writer = ei.WindowsScriptWriter
|
||||
if exec_param == sys.executable:
|
||||
# In case the path to the Python executable contains a space, wrap
|
||||
# it so it's not split up.
|
Loading…
Reference in New Issue
Block a user