new package: game-music-emu

This commit is contained in:
Tee KOBAYASHI 2022-04-10 18:27:17 +09:00 committed by xtkoba
parent 4db0a021cb
commit ed872ed00d
2 changed files with 23 additions and 0 deletions

View File

@ -0,0 +1,12 @@
TERMUX_PKG_HOMEPAGE=https://bitbucket.org/mpyne/game-music-emu/wiki/Home
TERMUX_PKG_DESCRIPTION="A collection of video game music file emulators"
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.6.3
TERMUX_PKG_SRCURL=https://bitbucket.org/mpyne/game-music-emu/downloads/game-music-emu-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=aba34e53ef0ec6a34b58b84e28bf8cfbccee6585cebca25333604c35db3e051d
TERMUX_PKG_DEPENDS="libc++, zlib"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DGME_YM2612_EMU=Nuked
-DENABLE_UBSAN=OFF
"

View File

@ -0,0 +1,11 @@
--- a/player/CMakeLists.txt
+++ b/player/CMakeLists.txt
@@ -6,7 +6,7 @@
Music_Player.h
player.cpp)
-if(SDL2_FOUND)
+if(FALSE)
message(" ** SDL 2 library located, player demo is available to be built in the /player directory")
include_directories(${SDL2_INCLUDE_DIRS} ${CMAKE_CURRENT_SOURCE_DIR}