mupdf: update Makefile.patch

Include changes from 7e6d92e63e

Should deal with errors like this one:

 CANNOT LINK EXECUTABLE "mutool": library "build/shared-release/libmupdf.so" not found
This commit is contained in:
Leonid Pliushch 2021-08-05 19:48:19 +03:00
parent 9e0233c06b
commit ed992bc0b9
No known key found for this signature in database
GPG Key ID: 45F2964132545795
2 changed files with 22 additions and 7 deletions

View File

@ -1,7 +1,22 @@
diff -uNr mupdf-1.15.0-source/Makefile mupdf-1.15.0-source.mod/Makefile
--- mupdf-1.15.0-source/Makefile 2019-05-06 14:53:09.000000000 +0300
+++ mupdf-1.15.0-source.mod/Makefile 2019-07-01 02:12:42.460143309 +0300
@@ -269,7 +269,7 @@
diff -uNr mupdf-1.18.0-source/Makefile mupdf-1.18.0-source.mod/Makefile
--- mupdf-1.18.0-source/Makefile 2020-10-07 13:35:03.000000000 +0300
+++ mupdf-1.18.0-source.mod/Makefile 2021-08-05 19:47:26.364131551 +0300
@@ -66,6 +66,14 @@
WINDRES_CMD = $(QUIET_WINDRES) $(MKTGTDIR) ; $(WINDRES) $< $@
OBJCOPY_CMD = $(QUIET_OBJCOPY) $(MKTGTDIR) ; $(LD) -r -b binary -z noexecstack -o $@ $<
+ifeq ($(shared),yes)
+LINK_CMD = $(QUIET_LINK) $(MKTGTDIR) ; $(CC) $(LDFLAGS) -o $@ \
+ $(filter-out %.$(SO),$^) \
+ $(sort $(patsubst %,-L%,$(dir $(filter %.$(SO),$^)))) \
+ $(patsubst lib%.$(SO),-l%,$(notdir $(filter %.$(SO),$^))) \
+ $(LIBS)
+endif
+
# --- Rules ---
$(OUT)/%.a :
@@ -321,7 +329,7 @@
$(OUT)/example: docs/examples/example.c $(MUPDF_LIB) $(THIRD_LIB)
$(LINK_CMD) $(CFLAGS) $(THIRD_LIBS)
$(OUT)/multi-threaded: docs/examples/multi-threaded.c $(MUPDF_LIB) $(THIRD_LIB)
@ -10,7 +25,7 @@ diff -uNr mupdf-1.15.0-source/Makefile mupdf-1.15.0-source.mod/Makefile
# --- Update version string header ---
@@ -303,7 +303,7 @@
@@ -355,7 +363,7 @@
tools: $(TOOL_APPS)
apps: $(TOOL_APPS) $(VIEW_APPS)
@ -19,7 +34,7 @@ diff -uNr mupdf-1.15.0-source/Makefile mupdf-1.15.0-source.mod/Makefile
install -d $(DESTDIR)$(incdir)/mupdf
install -d $(DESTDIR)$(incdir)/mupdf/fitz
install -d $(DESTDIR)$(incdir)/mupdf/pdf
@@ -315,7 +315,7 @@
@@ -367,7 +375,7 @@
install -m 644 $(INSTALL_LIBS) $(DESTDIR)$(libdir)
install -d $(DESTDIR)$(bindir)

View File

@ -3,7 +3,7 @@ TERMUX_PKG_DESCRIPTION="Lightweight PDF and XPS viewer (library)"
TERMUX_PKG_LICENSE="AGPL-V3"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.18.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://mupdf.com/downloads/archive/mupdf-${TERMUX_PKG_VERSION}-source.tar.xz
TERMUX_PKG_SHA256=592d4f6c0fba41bb954eb1a41616661b62b134d5b383e33bd45a081af5d4a59a
TERMUX_PKG_DEPENDS="freetype, gumbo-parser, harfbuzz, jbig2dec, libjpeg-turbo, openjpeg, zlib"