erlang: Update from 20.3.8 to 21.0.1
This commit is contained in:
parent
1d012a2173
commit
edd512a8f0
@ -1,7 +1,7 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.erlang.org/
|
||||
TERMUX_PKG_DESCRIPTION="General-purpose concurrent functional programming language developed by Ericsson"
|
||||
TERMUX_PKG_VERSION=20.3.8
|
||||
TERMUX_PKG_SHA256=a7e59c531605fbd19ceac0568ae81c89ec690449e861da6e3598399f9c4b747f
|
||||
TERMUX_PKG_VERSION=21.0.1
|
||||
TERMUX_PKG_SHA256=65a5f1c54bd52a5e9840cda536a2b37611bb08ab869295bba812c06c2bc7c9bc
|
||||
TERMUX_PKG_SRCURL=https://github.com/erlang/otp/archive/OTP-$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_DEPENDS="openssl, ncurses, libutil"
|
||||
TERMUX_PKG_HOSTBUILD="yes"
|
||||
@ -22,6 +22,8 @@ termux_step_host_build () {
|
||||
}
|
||||
|
||||
termux_step_pre_configure () {
|
||||
(cd erts && autoreconf)
|
||||
|
||||
# liblog is needed for syslog usage:
|
||||
LDFLAGS+=" -llog"
|
||||
# Put binaries built in termux_step_host_build at start of PATH:
|
||||
|
15
packages/erlang/erts-configure.in.patch
Normal file
15
packages/erlang/erts-configure.in.patch
Normal file
@ -0,0 +1,15 @@
|
||||
Submitted upstream: https://github.com/erlang/otp/pull/1861
|
||||
|
||||
diff -u -r ../otp-OTP-21.0.1/erts/configure.in ./erts/configure.in
|
||||
--- ../otp-OTP-21.0.1/erts/configure.in 2018-06-25 13:19:47.000000000 +0200
|
||||
+++ ./erts/configure.in 2018-07-01 17:57:13.738522618 +0200
|
||||
@@ -581,7 +581,8 @@
|
||||
PROFILE_INSTR_USE=false])
|
||||
rm -f default.profdata
|
||||
fi],
|
||||
- [])
|
||||
+ [],
|
||||
+ [AC_MSG_NOTICE([Disabling PGO when cross-compiling])])
|
||||
rm -f *.profraw
|
||||
CFLAGS=$saved_CFLAGS;
|
||||
fi
|
@ -1,3 +1,5 @@
|
||||
Based on the below change, updated for erlang 21:
|
||||
|
||||
From 85a3e5b4f65e5284e59dcdd90e92ea7d50ef6907 Mon Sep 17 00:00:00 2001
|
||||
From: Romain Naour <romain.naour@openwide.fr>
|
||||
Date: Sun, 8 Feb 2015 17:23:13 +0100
|
||||
@ -18,26 +20,26 @@ http://autobuild.buildroot.net/results/cbd/cbd8b54eef535f19d7d400fd269af1b3571d6
|
||||
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
|
||||
---
|
||||
erts/emulator/Makefile.in | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/erts/emulator/Makefile.in b/erts/emulator/Makefile.in
|
||||
index 7145824..d079487 100644
|
||||
--- a/erts/emulator/Makefile.in
|
||||
+++ b/erts/emulator/Makefile.in
|
||||
@@ -678,11 +678,11 @@ else
|
||||
diff -u -r ../otp-OTP-21.0.1/erts/emulator/Makefile.in ./erts/emulator/Makefile.in
|
||||
--- ../otp-OTP-21.0.1/erts/emulator/Makefile.in 2018-06-25 13:19:47.000000000 +0200
|
||||
+++ ./erts/emulator/Makefile.in 2018-07-01 18:06:51.931989663 +0200
|
||||
@@ -712,7 +712,7 @@
|
||||
# Usually the same as the default rule, but certain platforms (e.g. win32) mix
|
||||
# different compilers
|
||||
$(OBJDIR)/beam_emu.o: beam/beam_emu.c
|
||||
- $(V_EMU_CC) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) $(INCLUDES) -c $< -o $@
|
||||
+ $(V_EMU_CC) $(INCLUDES) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) -c $< -o $@
|
||||
endif
|
||||
|
||||
$(OBJDIR)/beam_emu.S: beam/beam_emu.c
|
||||
$(V_EMU_CC) -S -fverbose-asm $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) $(INCLUDES) -c $< -o $@
|
||||
@@ -765,7 +765,7 @@
|
||||
# General targets
|
||||
#
|
||||
$(OBJDIR)/%.o: beam/%.c
|
||||
- $(V_CC) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) $(INCLUDES) -c $< -o $@
|
||||
+ $(V_CC) $(INCLUDES) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) -c $< -o $@
|
||||
|
||||
$(OBJDIR)/%.o: $(TARGET)/%.c
|
||||
$(V_CC) $(CFLAGS) $(INCLUDES) -Idrivers/common -c $< -o $@
|
||||
--
|
||||
1.9.3
|
||||
|
Loading…
Reference in New Issue
Block a user