new package: jbig2enc

This commit is contained in:
Tee KOBAYASHI 2022-03-12 12:47:16 +09:00 committed by xtkoba
parent 4beb926c63
commit f3956ee0c8
3 changed files with 47 additions and 0 deletions

View File

@ -0,0 +1,25 @@
TERMUX_PKG_HOMEPAGE=https://github.com/agl/jbig2enc
TERMUX_PKG_DESCRIPTION="An encoder for JBIG2"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="@termux"
_COMMIT=ea6a40a2cbf05efb00f3418f2d0ad71232565beb
TERMUX_PKG_VERSION=2019.09.08
TERMUX_PKG_SRCURL=https://github.com/agl/jbig2enc.git
TERMUX_PKG_GIT_BRANCH=master
TERMUX_PKG_DEPENDS="giflib, leptonica, libc++, libjpeg-turbo, libpng, libtiff, libwebp, python, zlib"
termux_step_post_get_source() {
git fetch --unshallow
git checkout $_COMMIT
local version="$(git log -1 --format=%cs | sed 's/-/./g')"
if [ "$version" != "$TERMUX_PKG_VERSION" ]; then
echo -n "ERROR: The specified version \"$TERMUX_PKG_VERSION\""
echo " is different from what is expected to be: \"$version\""
return 1
fi
}
termux_step_pre_configure() {
sh autogen.sh
}

View File

@ -0,0 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
AC_INIT([jbig2enc], [0.28], [agl@imperialviolet.org], [jbig2enc-0.28],
[https://github.com/agl/jbig2enc])
AC_CONFIG_MACRO_DIR([m4])
-AM_INIT_AUTOMAKE([-Wall -Werror foreign no-dependencies])
+AM_INIT_AUTOMAKE([-Wall foreign no-dependencies])
# this should fix automake 1.12 build and compatible with automake 1.11
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])

View File

@ -0,0 +1,11 @@
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,7 +12,7 @@
bin_PROGRAMS = jbig2
jbig2_SOURCES = jbig2.cc
jbig2_LDADD = libjbig2enc.la
-jbig2_LDFLAGS = -static
+jbig2_LDFLAGS =
if MINGW
jbig2_LDADD += -lws2_32