ok, lr actually works for real now

This commit is contained in:
Lucy Phipps 2021-02-25 15:52:47 +00:00
parent 03d37233d5
commit f3c94728c2
No known key found for this signature in database
GPG Key ID: 8F688A3DB7869BFE
2 changed files with 5 additions and 3 deletions

View File

@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
index 5ef6fcd19..dd99a9d3d 100644
index 5ef6fcd19..23cd7f33c 100644
--- a/Makefile
+++ b/Makefile
@@ -4,10 +4,12 @@ ZSHCOMP=_lr
@ -16,13 +16,15 @@ index 5ef6fcd19..dd99a9d3d 100644
all: $(ALL)
@@ -19,5 +21,9 @@ install: FRC all
@@ -19,5 +21,11 @@ install: FRC all
install -m0755 $(ALL) $(DESTDIR)$(BINDIR)
install -m0644 $(ALL:=.1) $(DESTDIR)$(MANDIR)/man1
install -m0644 $(ZSHCOMP) $(DESTDIR)$(ZSHCOMPDIR)
+ install -m0755 contrib/lrls $(DESTDIR)$(BINDIR)
+ install -m0755 contrib/lrocate $(DESTDIR)$(BINDIR)
+ install -dm0755 $(DESTDIR)$(EMACSDIR)
+ install -m0644 contrib/lr.el $(DESTDIR)$(EMACSDIR)
+ install -dm0755 $(DESTDIR)$(VIMDIR)
+ install -m0644 contrib/lr.vim $(DESTDIR)$(VIMDIR)
FRC:

View File

@ -3,7 +3,7 @@ TERMUX_PKG_DESCRIPTION="list files, recursively, includes the best features of l
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.5.1
TERMUX_PKG_REVISION=4
TERMUX_PKG_REVISION=5
TERMUX_PKG_SRCURL=https://git.vuxu.org/lr/snapshot/lr-$TERMUX_PKG_VERSION.tar.xz
TERMUX_PKG_SHA256=147377be14805fe1fd7e01fe3cf4b2e0e34d98af5594743dbb97b12189fa52e1
TERMUX_PKG_BUILD_IN_SRC=true