proj: update to 6.2.1

This commit is contained in:
Henrik Grimler 2019-12-07 11:00:23 +01:00
parent 9793efeeca
commit f4071c3354
3 changed files with 48 additions and 3 deletions

View File

@ -0,0 +1,35 @@
commit fbb180464035f2dd573cbbe3aa722d5dec159ea2
Author: Mike Taves <mwtoews@gmail.com>
Date: Sat Nov 30 20:39:26 2019 +1300
Fix CMake build without tests
Fixes #1006
diff --git a/.gitignore b/.gitignore
index 1d28538b..57712f8b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -70,4 +70,5 @@ authors.git
!/docker/**/Makefile
/.vs*
.idea/
+.project
out/
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 93653818..77c93ed6 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -13,9 +13,11 @@
add_executable(example example.cpp)
target_link_libraries(example PRIVATE geos)
-target_include_directories(test_geos_unit
+if(BUILD_TESTING)
+ target_include_directories(test_geos_unit
PRIVATE
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}>)
+endif()
option(BUILD_DOCUMENTATION "Build Doxygen documentation" OFF)

View File

@ -0,0 +1,11 @@
--- ../inlines.cpp.orig 2019-12-07 11:13:58.242315736 +0000
+++ ./src/inlines.cpp 2019-12-07 11:14:56.612224731 +0000
@@ -33,7 +33,7 @@
// If using cygwin then we suppress the "multiple definition" errors by
// ignoring this section completely; the cygwin linker seems to handle
// the stubs correctly at link time by itself
-#if !defined(__CYGWIN__)
+#if !defined(__CYGWIN__) && !defined(__ANDROID__)
// Undefine GEOS_INLINE so that .inl files
// will be ready for an implementation file

View File

@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://proj.org
TERMUX_PKG_DESCRIPTION="Generic coordinate transformation software"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION=6.2.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=6.2.1
TERMUX_PKG_SRCURL=https://github.com/OSGeo/proj.4/archive/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=42b58adfd99f7ebeec8eaa8c9ba4b63792ad9e66b4aa89289e7a36030f3c5ee6
TERMUX_PKG_SHA256=fc49ef3ea7320186de8cd6b14095ae7aa510ee0e6f9123d10a7177872eae52b7
TERMUX_PKG_DEPENDS="libc++, libsqlite, sqlite"
TERMUX_PKG_BREAKS="proj-dev"
TERMUX_PKG_REPLACES="proj-dev"