ttyd: Add package at version 1.4.2

This commit is contained in:
Fredrik Fornwall 2018-09-15 01:47:10 +02:00
parent 3ad3fa5e7f
commit f46cd612e6
3 changed files with 30 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -u -r ../ttyd-1.4.2/CMakeLists.txt ./CMakeLists.txt
--- ../ttyd-1.4.2/CMakeLists.txt 2018-09-12 04:18:04.000000000 +0000
+++ ./CMakeLists.txt 2018-09-14 19:21:53.229336188 +0000
@@ -70,7 +70,7 @@
list(APPEND SOURCE_FILES html.h)
set(INCLUDE_DIRS ${OPENSSL_INCLUDE_DIR} ${LIBWEBSOCKETS_INCLUDE_DIR} ${JSON-C_INCLUDE_DIR})
-set(LINK_LIBS pthread ${OPENSSL_LIBRARIES} ${LIBWEBSOCKETS_LIBRARIES} ${JSON-C_LIBRARY})
+set(LINK_LIBS ${OPENSSL_LIBRARIES} ${LIBWEBSOCKETS_LIBRARIES} ${JSON-C_LIBRARY})
if(NOT APPLE)
list(APPEND LINK_LIBS util)

6
packages/ttyd/build.sh Normal file
View File

@ -0,0 +1,6 @@
TERMUX_PKG_HOMEPAGE=https://tsl0922.github.io/ttyd/
TERMUX_PKG_DESCRIPTION="Command-line tool for sharing terminal over the web"
TERMUX_PKG_VERSION=1.4.2
TERMUX_PKG_SHA256=ff1a66b418df6cd741868a8ea84f69cd63f15e52e3fa117641ec57d3c37a1315
TERMUX_PKG_SRCURL=https://github.com/tsl0922/ttyd/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_DEPENDS="json-c, libwebsockets, libutil"

View File

@ -0,0 +1,12 @@
diff -u -r ../ttyd-1.4.2/src/utils.c ./src/utils.c
--- ../ttyd-1.4.2/src/utils.c 2018-09-12 04:18:04.000000000 +0000
+++ ./src/utils.c 2018-09-14 19:18:03.508092637 +0000
@@ -5,7 +5,7 @@
#include <string.h>
#include <signal.h>
-#ifdef __linux__
+#if defined(__linux__) && !defined(__ANDROID__)
// https://github.com/karelzak/util-linux/blob/master/misc-utils/kill.c
const char *sys_signame[NSIG] = {
"zero", "HUP", "INT", "QUIT", "ILL", "TRAP", "ABRT", "UNUSED",