git: Update from 2.9.3 to 2.10.0

This commit is contained in:
Fredrik Fornwall 2016-09-03 17:32:42 -04:00
parent 7add3073f8
commit f7e141d03d
4 changed files with 26 additions and 25 deletions

View File

@ -2,8 +2,8 @@ TERMUX_PKG_HOMEPAGE=http://git-scm.com/
TERMUX_PKG_DESCRIPTION="Distributed version control system designed to handle everything from small to very large projects with speed and efficiency"
# less is required as a pager for git log, and the busybox less does not handle used escape sequences.
TERMUX_PKG_DEPENDS="libcurl, less"
TERMUX_PKG_VERSION=2.9.3
TERMUX_PKG_BUILD_REVISION=1
TERMUX_PKG_VERSION=2.10.0
TERMUX_PKG_SHA256=c73364ac00ae85ffc6cfb12ca2700bb0edf30f63262be97be4039be594ff29e7
TERMUX_PKG_SRCURL=https://www.kernel.org/pub/software/scm/git/git-${TERMUX_PKG_VERSION}.tar.xz
## This requires a working $TERMUX_PREFIX/bin/sh on the host building:
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--without-tcltk --with-curl --with-shell=$TERMUX_PREFIX/bin/sh ac_cv_header_libintl_h=no ac_cv_fread_reads_directories=yes ac_cv_snprintf_returns_bogus=yes"

View File

@ -0,0 +1,23 @@
Set uname_S to Linux instead of detecting build machine.
Android does not support -lrt.
diff -u -r ../git-2.10.0/config.mak.uname ./config.mak.uname
--- ../git-2.10.0/config.mak.uname 2016-09-02 21:59:09.000000000 -0400
+++ ./config.mak.uname 2016-09-03 17:27:41.964893344 -0400
@@ -1,6 +1,6 @@
# Platform specific Makefile tweaks based on uname detection
-uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
+uname_S := Linux
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')
uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
@@ -36,8 +36,6 @@
HAVE_DEV_TTY = YesPlease
HAVE_CLOCK_GETTIME = YesPlease
HAVE_CLOCK_MONOTONIC = YesPlease
- # -lrt is needed for clock_gettime on glibc <= 2.16
- NEEDS_LIBRT = YesPlease
HAVE_GETDELIM = YesPlease
SANE_TEXT_GREP=-a
endif

View File

@ -1,17 +1,5 @@
* Set uname_S to Linux instead of detecting build machine.
* Fix ST_CTIME_NSEC and ST_MTIME_NSEC macros on Android.
Fix ST_CTIME_NSEC and ST_MTIME_NSEC macros on Android.
diff -u -r ../git-1.8.5.3/config.mak.uname ./config.mak.uname
--- ../git-1.8.5.3/config.mak.uname 2014-01-14 18:10:09.000000000 +0100
+++ ./config.mak.uname 2014-01-22 16:53:42.000000000 +0100
@@ -1,6 +1,6 @@
# Platform specific Makefile tweaks based on uname detection
-uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
+uname_S := Linux
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')
uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
diff -u -r ../git-1.8.5.3/git-compat-util.h ./git-compat-util.h
--- ../git-1.8.5.3/git-compat-util.h 2014-01-14 18:10:09.000000000 +0100
+++ ./git-compat-util.h 2014-01-22 13:07:19.000000000 +0100

View File

@ -1,5 +1,3 @@
The librt functionality is built into libc on Android.
The Termux git package installs git perl files to $PREFIX/share/git-perl
by patching perl/Makefile.PL, so setup that path when building perl
files in this Makefile.
@ -7,14 +5,6 @@ files in this Makefile.
diff -u -r ../git-2.7.4/Makefile ./Makefile
--- ../git-2.7.4/Makefile 2016-03-17 16:47:59.000000000 -0400
+++ ./Makefile 2016-03-24 22:46:20.335193973 -0400
@@ -1455,7 +1455,6 @@
ifdef HAVE_CLOCK_GETTIME
BASIC_CFLAGS += -DHAVE_CLOCK_GETTIME
- EXTLIBS += -lrt
endif
ifdef HAVE_CLOCK_MONOTONIC
@@ -1789,7 +1788,7 @@
sed -e '1{' \
-e ' s|#!.*perl|#!$(PERL_PATH_SQ)|' \