new package: id3lib
This commit is contained in:
parent
1fe661b544
commit
fa5e92512b
28
packages/id3lib/build.sh
Normal file
28
packages/id3lib/build.sh
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
TERMUX_PKG_HOMEPAGE=http://id3lib.sourceforge.net/
|
||||||
|
TERMUX_PKG_DESCRIPTION="A software library for manipulating ID3v1/v1.1 and ID3v2 tags"
|
||||||
|
TERMUX_PKG_LICENSE="LGPL-2.0"
|
||||||
|
TERMUX_PKG_MAINTAINER="@termux"
|
||||||
|
TERMUX_PKG_VERSION=3.8.3
|
||||||
|
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/id3lib/id3lib-${TERMUX_PKG_VERSION}.tar.gz
|
||||||
|
TERMUX_PKG_SHA256=2749cc3c0cd7280b299518b1ddf5a5bcfe2d1100614519b68702230e26c7d079
|
||||||
|
TERMUX_PKG_DEPENDS="libc++, libiconv, zlib"
|
||||||
|
|
||||||
|
termux_step_pre_configure() {
|
||||||
|
for f in examples/demo_*.cpp; do
|
||||||
|
sed -i -e 's/^int main( unsigned int /int main( int /g' $f
|
||||||
|
done
|
||||||
|
|
||||||
|
_ID3LIB_MAJOR=$(awk -F= '/^ID3LIB_MAJOR_/ { print $2 }' configure.in)
|
||||||
|
_ID3LIB_MINOR=$(awk -F= '/^ID3LIB_MINOR_/ { print $2 }' configure.in)
|
||||||
|
|
||||||
|
autoreconf -fi
|
||||||
|
}
|
||||||
|
|
||||||
|
termux_step_post_make_install() {
|
||||||
|
_LIBID3_SO=libid3-${_ID3LIB_MAJOR}.${_ID3LIB_MINOR}.so
|
||||||
|
if [ ! -e $TERMUX_PREFIX/lib/$_LIBID3_SO ]; then
|
||||||
|
echo "ERROR: $_LIBID3_SO not found."
|
||||||
|
return 1
|
||||||
|
fi
|
||||||
|
ln -sf $_LIBID3_SO $TERMUX_PREFIX/lib/libid3.so
|
||||||
|
}
|
37
packages/id3lib/configure.in.patch
Normal file
37
packages/id3lib/configure.in.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -168,7 +168,7 @@
|
||||||
|
iconv_oldstyle=1, iconv_oldstyle=0)
|
||||||
|
if test $iconv_oldstyle = 1; then
|
||||||
|
AC_MSG_RESULT(const char **)
|
||||||
|
- AC_DEFINE(ID3LIB_ICONV_OLDSTYLE)
|
||||||
|
+ AC_DEFINE(ID3LIB_ICONV_OLDSTYLE, [], [No description.])
|
||||||
|
#we'll check out the need of
|
||||||
|
#typecast in the call of iconv_open
|
||||||
|
AC_MSG_CHECKING(whether to typecast in iconv)
|
||||||
|
@@ -184,7 +184,7 @@
|
||||||
|
iconv_cast=0, iconv_cast=1)
|
||||||
|
if test $iconv_cast = 1; then
|
||||||
|
AC_MSG_RESULT(yes)
|
||||||
|
- AC_DEFINE(ID3LIB_ICONV_CAST_OK)
|
||||||
|
+ AC_DEFINE(ID3LIB_ICONV_CAST_OK, [], [No description.])
|
||||||
|
else
|
||||||
|
AC_MSG_RESULT(no)
|
||||||
|
fi
|
||||||
|
@@ -206,7 +206,7 @@
|
||||||
|
iconv_cast=0, iconv_cast=1)
|
||||||
|
if test $iconv_cast = 1; then
|
||||||
|
AC_MSG_RESULT(yes)
|
||||||
|
- AC_DEFINE(ID3LIB_ICONV_CAST_OK)
|
||||||
|
+ AC_DEFINE(ID3LIB_ICONV_CAST_OK, [], [No description.])
|
||||||
|
else
|
||||||
|
AC_MSG_RESULT(no)
|
||||||
|
fi
|
||||||
|
@@ -227,7 +227,6 @@
|
||||||
|
)
|
||||||
|
AC_CHECK_HEADERS( \
|
||||||
|
string \
|
||||||
|
- iomanip.h \
|
||||||
|
,,AC_MSG_ERROR([Missing a vital header file for id3lib])
|
||||||
|
)
|
||||||
|
|
Loading…
Reference in New Issue
Block a user