new package: libt3widget

This commit is contained in:
Tee KOBAYASHI 2022-02-02 11:00:18 +09:00 committed by xtkoba
parent 460f0370c7
commit fab75b88cd
2 changed files with 49 additions and 0 deletions

View File

@ -0,0 +1,39 @@
TERMUX_PKG_HOMEPAGE=https://os.ghalkes.nl/t3/libt3widget.html
TERMUX_PKG_DESCRIPTION="A library of widgets and dialogs to facilitate construction of easy-to-use terminal-based programs"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.2.2
TERMUX_PKG_SRCURL=https://os.ghalkes.nl/dist/libt3widget-${TERMUX_PKG_VERSION}.tar.bz2
TERMUX_PKG_SHA256=9eb7e1d0ccdfc917f18ba1785a2edb4faa6b0af8b460653d962abf91136ddf1c
TERMUX_PKG_DEPENDS="libc++, libt3key, libt3window, libtranscript, libunistring, pcre2"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--without-gettext
--without-x11
--without-gpm
"
termux_step_post_get_source() {
sed -i 's/ -s / /g' Makefile.in
}
termux_step_pre_configure() {
local libtooldir=$TERMUX_PKG_TMPDIR/_libtool
mkdir -p $libtooldir
pushd $libtooldir
cat > configure.ac <<-EOF
AC_INIT
LT_INIT
AC_PROG_CXX
AC_OUTPUT
EOF
touch install-sh
cp "$TERMUX_SCRIPTDIR/scripts/config.sub" ./
cp "$TERMUX_SCRIPTDIR/scripts/config.guess" ./
autoreconf -fi
./configure --host=$TERMUX_HOST_PLATFORM
popd
export LIBTOOL=$libtooldir/libtool
CXXFLAGS+=" $CPPFLAGS"
}

View File

@ -0,0 +1,10 @@
--- a/src/widgets/menu.cc
+++ b/src/widgets/menu.cc
@@ -11,7 +11,6 @@
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-#include <ext/alloc_traits.h>
#include <memory>
#include <type_traits>
#include <utility>