freeimage: fixes (#7371)
* libm was missing * disable arm-neon optimisation in LibPng since arm code is missing (which gave undefined error) * swab patch was included but not compiled
This commit is contained in:
parent
13be2e3059
commit
faf4413089
@ -1,5 +1,30 @@
|
||||
--- a/Makefile.gnu
|
||||
+++ b/Makefile.gnu
|
||||
--- FreeImage/Makefile.gnu 2021-08-20 21:04:25.244999878 +0530
|
||||
+++ FreeImage-patch/Makefile.gnu 2021-08-21 10:28:21.714786780 +0530
|
||||
@@ -5,19 +5,19 @@
|
||||
|
||||
# General configuration variables:
|
||||
DESTDIR ?= /
|
||||
-INCDIR ?= $(DESTDIR)/usr/include
|
||||
-INSTALLDIR ?= $(DESTDIR)/usr/lib
|
||||
+INCDIR ?= @TERMUX_PREFIX@/include
|
||||
+INSTALLDIR ?= @TERMUX_PREFIX@/lib
|
||||
|
||||
# Converts cr/lf to just lf
|
||||
DOS2UNIX = dos2unix
|
||||
|
||||
-LIBRARIES = -lstdc++
|
||||
+LIBRARIES = -lstdc++ -lm
|
||||
|
||||
MODULES = $(SRCS:.c=.o)
|
||||
MODULES := $(MODULES:.cpp=.o)
|
||||
-CFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden
|
||||
+CFLAGS ?= -O3 -fPIC -fexceptions -fvisibility=hidden -fstack-protector-strong -Oz
|
||||
# OpenJPEG
|
||||
-CFLAGS += -DOPJ_STATIC
|
||||
+CFLAGS += -DOPJ_STATIC -DPNG_ARM_NEON_OPT=0
|
||||
# LibRaw
|
||||
CFLAGS += -DNO_LCMS
|
||||
# LibJXR
|
||||
@@ -71,9 +71,9 @@
|
||||
|
||||
install:
|
||||
|
File diff suppressed because one or more lines are too long
@ -1,15 +1,18 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://freeimage.sourceforge.io
|
||||
TERMUX_PKG_HOMEPAGE="https://freeimage.sourceforge.io"
|
||||
TERMUX_PKG_DESCRIPTION="The library project for developers who would like to support popular graphics image formats."
|
||||
TERMUX_PKG_LICENSE="custom"
|
||||
TERMUX_PKG_LICENSE_FILE="license-fi.txt, license-gplv2.txt, license-gplv3.txt, license-bsd-2-clause.txt"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=3.18.0
|
||||
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/project/freeimage/Source%20Distribution/${TERMUX_PKG_VERSION}/FreeImage${TERMUX_PKG_VERSION//./}.zip
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL="https://downloads.sourceforge.net/project/freeimage/Source%20Distribution/${TERMUX_PKG_VERSION}/FreeImage${TERMUX_PKG_VERSION//./}.zip"
|
||||
TERMUX_PKG_SHA256=f41379682f9ada94ea7b34fe86bf9ee00935a3147be41b6569c9605a53e438fd
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_EXTRA_MAKE_ARGS="DESTDIR=${TERMUX_PREFIX}/../"
|
||||
TERMUX_PKG_MAKE_INSTALL_TARGET="DESTDIR=${TERMUX_PREFIX}/../ install"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
cp -f $TERMUX_PKG_BUILDER_DIR/license-bsd-2-clause.txt $TERMUX_PKG_SRCDIR/
|
||||
cp -f "${TERMUX_PKG_BUILDER_DIR}/license-bsd-2-clause.txt" "${TERMUX_PKG_SRCDIR}"
|
||||
}
|
||||
|
||||
termux_step_make() {
|
||||
make LDFLAGS="${LDFLAGS}"
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user