eab39222c5
Currently it supports only on-device builds. https://github.com/termux/termux-packages/pull/4895 How to build: cp -a ./disabled-packages/swift ./packages/ pkg install clang binutils-gold file patch python cmake ninja python2 perl rsync libandroid-spawn libcurl libicu libsqlite libuuid libxml2 llbuild pkg-config TERMUX_MAKE_PROCESSES=7 ./build-package.sh swift
13 lines
535 B
Diff
13 lines
535 B
Diff
diff --git a/swift-corelibs-xctest/CMakeLists.txt b/swift-corelibs-xctest/CMakeLists.txt
|
|
index 8c9800f..a29a514 100644
|
|
--- a/swift-corelibs-xctest/CMakeLists.txt
|
|
+++ b/swift-corelibs-xctest/CMakeLists.txt
|
|
@@ -55,6 +55,7 @@ add_swift_library(XCTest
|
|
|
|
# compatibility with Foundation build_script.py
|
|
-L${XCTEST_PATH_TO_FOUNDATION_BUILD}/Foundation
|
|
+ -Xlinker -rpath -Xlinker "\\\$\$ORIGIN"
|
|
|
|
${WORKAROUND_SR9138}
|
|
${WORKAROUND_SR9995}
|