39 lines
1.6 KiB
Diff
39 lines
1.6 KiB
Diff
--- ./Makefile.rules.orig 2021-03-02 15:12:10.000000000 +0000
|
|
+++ ./Makefile.rules 2021-06-10 19:13:39.230787541 +0000
|
|
@@ -484,9 +484,7 @@
|
|
|
|
LTINSTALL=$(LIBTOOL) --mode=install $(INSTALL)
|
|
|
|
-install:
|
|
- @echo "Error, 'make install' has not yet been implemented"
|
|
- exit 1
|
|
+install: install-libgap install-headers install-bin install-gaproot install-pkg
|
|
|
|
# the following is wrapper script which is installed by the install-bin target
|
|
define gap_wrapper
|
|
@@ -498,13 +496,13 @@
|
|
install-bin:
|
|
@echo "Warning, 'make install-bin' is incomplete"
|
|
$(INSTALL) -d -m 0755 $(DESTDIR)$(bindir)
|
|
- $(INSTALL) -m 0755 gap $(DESTDIR)$(bindir)/gap.real
|
|
- echo "$$gap_wrapper" > gap-wrapper.sh
|
|
+ $(INSTALL) -m 0755 gap $(PREFIX)/libexec/gap.real
|
|
+ echo -e "#!@TERMUX_PREFIX@/bin/sh\nexec \"$(PREFIX)/libexec/gap.real\" -l \"$(datarootdir)/gap\" "'"$$@"' > gap-wrapper.sh
|
|
$(INSTALL) -m 0755 gap-wrapper.sh $(DESTDIR)$(bindir)/gap
|
|
# TODO: make gac installable; this requires adjusting path in it, and
|
|
# installing the libtool script generated by configure somewhere; and then
|
|
# putting that path to it into gac)
|
|
- #$(INSTALL) gac $(DESTDIR)$(bindir)
|
|
+ $(INSTALL) gac $(DESTDIR)$(bindir)
|
|
|
|
install-gaproot:
|
|
@echo "Warning, 'make install-gaproot' is incomplete"
|
|
@@ -544,6 +542,7 @@
|
|
$(INSTALL) -d -m 0755 $(DESTDIR)$(includedir)/gap/hpc
|
|
$(INSTALL) -m 0644 $(srcdir)/src/hpc/*.h $(DESTDIR)$(includedir)/gap/hpc
|
|
# TODO: take care of config.h, this is difficult
|
|
+ $(INSTALL) -m 0644 gen/config.h $(DESTDIR)$(includedir)/gap
|
|
|
|
install-libgap: libgap.la
|
|
@echo "Warning, 'make install-libgap' is incomplete"
|