54 lines
1.9 KiB
Diff
54 lines
1.9 KiB
Diff
diff -uNr apt-2.1.11/apt-pkg/CMakeLists.txt apt-2.1.11.mod/apt-pkg/CMakeLists.txt
|
|
--- apt-2.1.11/apt-pkg/CMakeLists.txt 2020-10-21 12:53:18.000000000 +0300
|
|
+++ apt-2.1.11.mod/apt-pkg/CMakeLists.txt 2020-11-05 13:54:37.761890653 +0200
|
|
@@ -52,7 +52,7 @@
|
|
)
|
|
|
|
target_link_libraries(apt-pkg
|
|
- PRIVATE -lutil ${CMAKE_DL_LIBS} ${RESOLV_LIBRARIES}
|
|
+ PRIVATE ${CMAKE_DL_LIBS} ${RESOLV_LIBRARIES}
|
|
${CMAKE_THREAD_LIBS_INIT}
|
|
${ZLIB_LIBRARIES}
|
|
${BZIP2_LIBRARIES}
|
|
diff -uNr apt-2.1.11/CMakeLists.txt apt-2.1.11.mod/CMakeLists.txt
|
|
--- apt-2.1.11/CMakeLists.txt 2020-10-21 12:53:18.000000000 +0300
|
|
+++ apt-2.1.11.mod/CMakeLists.txt 2020-11-05 14:12:13.701910799 +0200
|
|
@@ -188,14 +188,6 @@
|
|
endif()
|
|
endif()
|
|
|
|
-# Handle resolving
|
|
-check_function_exists(res_ninit HAVE_LIBC_RESOLV)
|
|
-if(HAVE_LIBC_RESOLV)
|
|
- set(RESOLV_LIBRARIES)
|
|
-else()
|
|
- set(RESOLV_LIBRARIES -lresolv)
|
|
-endif()
|
|
-
|
|
# Check multiversioning
|
|
include(CheckCxxTarget)
|
|
check_cxx_target(HAVE_FMV_SSE42_AND_CRC32 "sse4.2" "__builtin_ia32_crc32si(0,i)|__builtin_ia32_crc32hi(0,i)|__builtin_ia32_crc32qi(0,i)")
|
|
@@ -213,10 +205,6 @@
|
|
message(STATUS "Found dpkg data dir: ${DPKG_DATADIR_CMD}")
|
|
set(DPKG_DATADIR "${DPKG_DATADIR_CMD}" CACHE PATH "dpkg data directory")
|
|
endif()
|
|
-if (NOT DEFINED COMMON_ARCH)
|
|
- execute_process(COMMAND dpkg-architecture -qDEB_HOST_ARCH
|
|
- OUTPUT_VARIABLE COMMON_ARCH OUTPUT_STRIP_TRAILING_WHITESPACE)
|
|
-endif()
|
|
if (NOT DEFINED ROOT_GROUP)
|
|
execute_process(COMMAND id -gn root
|
|
OUTPUT_VARIABLE ROOT_GROUP OUTPUT_STRIP_TRAILING_WHITESPACE)
|
|
@@ -243,11 +231,9 @@
|
|
add_subdirectory(apt-private)
|
|
add_subdirectory(cmdline)
|
|
add_subdirectory(completions)
|
|
-add_subdirectory(doc)
|
|
add_subdirectory(dselect)
|
|
add_subdirectory(ftparchive)
|
|
add_subdirectory(methods)
|
|
-add_subdirectory(test)
|
|
|
|
if (USE_NLS)
|
|
add_subdirectory(po)
|