termux-packages/packages/ghc-libs/utils-extra-ghc-opts.patch
Aditya Alok 80f7a2a0df refactor(ghc-libs): rename ghc to ghc-libs
- seperate ghc libraries from ghc bins
- enable dynamic libs for ghc
  * ghc-libs is further seperated into static and dynamic packages
  * enabling dynamic support will reduce package size as well as there
    performance  on device.

closes #5973

Signed-off-by: Aditya Alok <dev.aditya.alok@gmail.com>
2022-03-09 10:01:57 +09:00

18 lines
525 B
Diff

--- ghc-8.10.7/rules/package-config.mk 2022-02-09 09:22:35.911445951 +0530
+++ ghc-8.10.7-patch/rules/package-config.mk 2022-02-11 09:40:05.957999047 +0530
@@ -55,6 +55,14 @@
$1_$2_MORE_HC_OPTS += -rtsopts
endif
+ifneq "$3" "0"
+ifneq (,$(findstring utils/,$1))
+# Found a package that needs to be built in the utils directory
+$1_$2_MORE_HC_OPTS += -optl-Wl,-rpath=@TERMUX_PREFIX@/lib
+$1_$2_MORE_HC_OPTS += -optl-Wl,--enable-new-dtags
+endif
+endif
+
# Used by pretty_commands.mk
label_$1_$2_CC=CC
label_$1_$2_AS=AS