50 lines
1.8 KiB
Diff
50 lines
1.8 KiB
Diff
diff -u -r ../coreutils-8.26/Makefile.in ./Makefile.in
|
|
--- ../coreutils-8.26/Makefile.in 2016-11-30 13:34:55.000000000 -0500
|
|
+++ ./Makefile.in 2016-11-30 19:10:09.902334174 -0500
|
|
@@ -5023,7 +5023,9 @@
|
|
@CROSS_COMPILING_FALSE@cu_install_program = src/ginstall
|
|
|
|
# Use the just-built 'ginstall', when not cross-compiling.
|
|
-@CROSS_COMPILING_TRUE@cu_install_program = @INSTALL_PROGRAM@
|
|
+# Work around
|
|
+# "Makefile:3440: *** Recursive variable 'INSTALL' references itself (eventually). Stop."
|
|
+@CROSS_COMPILING_TRUE@cu_install_program = install
|
|
info_TEXINFOS = doc/coreutils.texi
|
|
doc_coreutils_TEXINFOS = \
|
|
doc/perm.texi \
|
|
@@ -14622,32 +14624,8 @@
|
|
@SINGLE_BINARY_FALSE@man/yes.1: src/yes$(EXEEXT)
|
|
|
|
.x.1:
|
|
- $(AM_V_GEN)name=`echo $@ | sed 's|.*/||; s|\.1$$||'` || exit 1; \
|
|
- case $$name in \
|
|
- install) prog='ginstall'; argv=$$name;; \
|
|
- test) prog='['; argv='[';; \
|
|
- *) prog=$$name; argv=$$prog;; \
|
|
- esac; \
|
|
- rm -f $@ $@-t \
|
|
- && t=$*.td \
|
|
- && rm -rf $$t \
|
|
- && $(MKDIR_P) $$t \
|
|
- && (cd $$t && $(LN_S) '$(abs_top_builddir)/src/'$$prog$(EXEEXT) \
|
|
- $$argv$(EXEEXT)) \
|
|
- && : $${SOURCE_DATE_EPOCH=`cat $(srcdir)/.timestamp 2>/dev/null || :`} \
|
|
- && export SOURCE_DATE_EPOCH && $(run_help2man) \
|
|
- --source='$(PACKAGE_STRING)' \
|
|
- --include=$(srcdir)/man/$$name.x \
|
|
- --output=$$t/$$name.1 \
|
|
- --info-page='\(aq(coreutils) '$$name' invocation\(aq' \
|
|
- $$t/$$argv$(EXEEXT) \
|
|
- && sed \
|
|
- -e 's|$*\.td/||g' \
|
|
- -e '/For complete documentation/d' \
|
|
- $$t/$$name.1 > $@-t \
|
|
- && rm -rf $$t \
|
|
- && chmod a-w $@-t \
|
|
- && mv $@-t $@
|
|
+ # Use man pages generated by help2man in the host build.
|
|
+ cp $(top_srcdir)/../host-build/$@ $@
|
|
.PHONY: check-root
|
|
check-root:
|
|
$(MAKE) check TESTS='$(root_tests)' SUBDIRS=.
|