termux-packages/packages/ccache/no-cpu-features.patch

36 lines
1.2 KiB
Diff

diff -uNr ccache-4.0/src/third_party/blake3/CMakeLists.txt ccache-4.0.mod/src/third_party/blake3/CMakeLists.txt
--- ccache-4.0/src/third_party/blake3/CMakeLists.txt 2020-10-18 18:55:03.000000000 +0000
+++ ccache-4.0.mod/src/third_party/blake3/CMakeLists.txt 2020-11-22 00:29:11.795911551 +0000
@@ -21,15 +21,8 @@
check_c_compiler_flag(${compile_flags} ${have_feature})
endif()
- if(${have_feature})
- target_sources(blake3 PRIVATE blake3_${feature}${blake_suffix})
- set_property(
- SOURCE blake3_${feature}${blake_suffix}
- APPEND PROPERTY COMPILE_FLAGS ${compile_flags})
- else()
- string(TOUPPER "blake3_no_${feature}" no_feature)
- target_compile_definitions(blake3 PRIVATE ${no_feature})
- endif()
+ string(TOUPPER "blake3_no_${feature}" no_feature)
+ target_compile_definitions(blake3 PRIVATE ${no_feature})
endfunction()
add_source_if_enabled(sse2 "-msse2")
diff -uNr ccache-4.1/src/hashutil.cpp ccache-4.1.mod/src/hashutil.cpp
--- ccache-4.1/src/hashutil.cpp 2020-11-22 20:00:22.000000000 +0000
+++ ccache-4.1.mod/src/hashutil.cpp 2020-11-23 06:32:36.609734222 +0000
@@ -39,6 +39,10 @@
# include "Win32Util.hpp"
#endif
+#ifdef __ANDROID__
+# undef HAVE_AVX2
+#endif
+
#ifdef HAVE_AVX2
# include <immintrin.h>
#endif