24 lines
967 B
Diff
24 lines
967 B
Diff
diff -u -r ../pycryptopp-pycryptopp-0.6.0/setup.py ./setup.py
|
|
--- ../pycryptopp-pycryptopp-0.6.0/setup.py 2012-03-13 04:16:09.000000000 -0400
|
|
+++ ./setup.py 2016-01-20 19:54:13.085989935 -0500
|
|
@@ -57,8 +57,8 @@
|
|
undef_macros=[]
|
|
libraries=[]
|
|
ext_modules=[]
|
|
-include_dirs=[]
|
|
-library_dirs=[]
|
|
+include_dirs = ['/data/data/com.termux/files/usr/include', '/data/data/com.termux/files/usr/include/python2.7']
|
|
+library_dirs = ['/data/data/com.termux/files/usr/lib']
|
|
extra_srcs=[] # This is for Crypto++ .cpp files if they are needed.
|
|
|
|
#
|
|
@@ -208,7 +208,7 @@
|
|
for s in os.listdir(os.path.join("src-ed25519","supercop-ref"))
|
|
if s.endswith(".c") and s!="test.c"])
|
|
m = Extension("pycryptopp.publickey.ed25519._ed25519",
|
|
- include_dirs=[os.path.join("src-ed25519","supercop-ref")],
|
|
+ include_dirs=[os.path.join("src-ed25519","supercop-ref")] + include_dirs,
|
|
sources=sources)
|
|
ext_modules.append(m)
|
|
|