49 lines
1.3 KiB
Diff
49 lines
1.3 KiB
Diff
--- src/CMakeLists.txt 2021-04-16 16:36:14.000000000 +0000
|
|
+++ src.mod/CMakeLists.txt 2021-05-20 14:57:23.675649000 +0000
|
|
@@ -32,12 +32,7 @@
|
|
find_package(X11 REQUIRED)
|
|
message(STATUS "Building with Qt${Qt5Core_VERSION}")
|
|
find_package(PkgConfig REQUIRED)
|
|
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
|
|
- pkg_search_module(PROCPS REQUIRED libprocps)
|
|
-endif()
|
|
-
|
|
-# Please don't move, must be after lxqt
|
|
-find_package(XdgUserDirs REQUIRED)
|
|
+pkg_search_module(PROCPS REQUIRED libprocps)
|
|
|
|
# Patch Version
|
|
set(LXQT_SESSION_PATCH_VERSION 1)
|
|
--- src/lxqt-session/CMakeLists.txt 2021-04-16 16:36:14.000000000 +0000
|
|
+++ src.mod/lxqt-session/CMakeLists.txt 2021-05-20 15:00:28.556372000 +0000
|
|
@@ -9,11 +9,9 @@
|
|
include_directories(
|
|
${X11_INCLUDE_DIR}
|
|
)
|
|
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
|
|
- include_directories(
|
|
- ${PROCPS_INCLUDE_DIRS}
|
|
- )
|
|
-endif()
|
|
+include_directories(
|
|
+ ${PROCPS_INCLUDE_DIRS}
|
|
+)
|
|
|
|
set(lxqt-session_HDRS "")
|
|
|
|
@@ -67,11 +65,9 @@
|
|
${X11_LIBRARIES}
|
|
KF5::WindowSystem
|
|
)
|
|
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
|
|
- target_link_libraries(lxqt-session
|
|
- ${PROCPS_LIBRARIES}
|
|
- )
|
|
-endif()
|
|
+target_link_libraries(lxqt-session
|
|
+ ${PROCPS_LIBRARIES}
|
|
+)
|
|
|
|
if (WITH_LIBUDEV)
|
|
target_link_libraries(lxqt-session ${UDEV_LIBS})
|