termux-packages/packages/coreutils/makefile.patch

37 lines
1.2 KiB
Diff

Use man pages generated by help2man in the host build.
diff -u -r ../coreutils-8.23/Makefile.in ./Makefile.in
--- ../coreutils-8.23/Makefile.in 2014-07-19 00:22:24.000000000 +0200
+++ ./Makefile.in 2014-07-29 15:52:14.000000000 +0200
@@ -14062,29 +14062,7 @@
@AMDEP_TRUE@@am__include@ man/dynamic-deps.mk
.x.1:
- $(AM_V_GEN)name=`echo $@ | sed 's|.*/||; s|\.1$$||'` || exit 1; \
- case $$name in \
- install) prog='ginstall'; argv=$$name;; \
- test) prog='['; argv='[';; \
- *) prog=$$name; argv=$$prog;; \
- esac; \
- rm -f $@ $@-t \
- && t=$*.td \
- && rm -rf $$t \
- && $(MKDIR_P) $$t \
- && (cd $$t && $(LN_S) '$(abs_top_builddir)/src/'$$prog $$argv) \
- && $(run_help2man) \
- --source='$(PACKAGE_STRING)' \
- --include=$(srcdir)/man/$$name.x \
- --output=$$t/$$name.1 $$t/$$argv \
- --info-page='coreutils \(aq'$$name' invocation\(aq' \
- && sed \
- -e 's|$*\.td/||g' \
- -e '/For complete documentation/d' \
- $$t/$$name.1 > $@-t \
- && rm -rf $$t \
- && chmod a-w $@-t \
- && mv $@-t $@
+ cp $(top_srcdir)/../host-build/$@ $@
.PHONY: check-root
check-root:
$(MAKE) check TESTS='$(root_tests)' SUBDIRS=.