termux-packages/packages/lua/Makefile.patch

18 lines
701 B
Diff

diff -u -r ../lua-5.3.0/Makefile ./Makefile
--- ../lua-5.3.0/Makefile 2014-10-29 19:14:41.000000000 -0400
+++ ./Makefile 2015-05-24 18:05:30.039061174 -0400
@@ -10,11 +10,11 @@
# so take care if INSTALL_TOP is not an absolute path. See the local target.
# You may want to make INSTALL_LMOD and INSTALL_CMOD consistent with
# LUA_ROOT, LUA_LDIR, and LUA_CDIR in luaconf.h.
-INSTALL_TOP= /usr/local
+INSTALL_TOP= @TERMUX_PREFIX@
INSTALL_BIN= $(INSTALL_TOP)/bin
INSTALL_INC= $(INSTALL_TOP)/include
INSTALL_LIB= $(INSTALL_TOP)/lib
-INSTALL_MAN= $(INSTALL_TOP)/man/man1
+INSTALL_MAN= $(INSTALL_TOP)/share/man/man1
INSTALL_LMOD= $(INSTALL_TOP)/share/lua/$V
INSTALL_CMOD= $(INSTALL_TOP)/lib/lua/$V