termux-packages/packages/libmosquitto/config.patch

37 lines
1.0 KiB
Diff

diff --git a/config.mk b/config.mk
index 087766c..6ff9bc1 100644
--- a/config.mk
+++ b/config.mk
@@ -26,10 +26,10 @@ WITH_TLS:=yes
# Comment out to disable TLS/PSK support in the broker and client. Requires
# WITH_TLS=yes.
# This must be disabled if using openssl < 1.0.
-WITH_TLS_PSK:=yes
+WITH_TLS_PSK:=no
# Comment out to disable client client threading support.
-WITH_THREADING:=yes
+WITH_THREADING:=no
# Comment out to remove bridge support from the broker. This allow the broker
# to connect to other brokers and subscribe/publish to topics. You probably
@@ -124,8 +124,7 @@ LIB_LIBS:=
PASSWD_LIBS:=
ifeq ($(UNAME),Linux)
- BROKER_LIBS:=$(BROKER_LIBS) -lrt -Wl,--dynamic-list=linker.syms
- LIB_LIBS:=$(LIB_LIBS) -lrt
+ BROKER_LIBS:=$(BROKER_LIBS) -Wl,--dynamic-list=linker.syms
endif
CLIENT_LDFLAGS:=$(LDFLAGS) -L../lib ../lib/libmosquitto.so.${SOVERSION}
@@ -241,7 +240,7 @@ ifeq ($(WITH_DOCS),yes)
endif
INSTALL?=install
-prefix=/usr/local
+prefix=
mandir=${prefix}/share/man
localedir=${prefix}/share/locale
STRIP?=strip