54 lines
2.0 KiB
Diff
54 lines
2.0 KiB
Diff
diff -uNr newsboat-2.17/rust/libnewsboat/Cargo.toml newsboat-2.17.mod/rust/libnewsboat/Cargo.toml
|
|
--- newsboat-2.17/rust/libnewsboat/Cargo.toml 2019-09-22 17:19:19.000000000 +0300
|
|
+++ newsboat-2.17.mod/rust/libnewsboat/Cargo.toml 2019-09-24 20:57:10.680900795 +0300
|
|
@@ -19,7 +19,6 @@
|
|
unicode-segmentation = "1"
|
|
curl-sys = "0.4.5"
|
|
libc = "0.2"
|
|
-gettext-rs = "0.4.1"
|
|
natord = "1.0.9"
|
|
|
|
# We don't use the following crates, but we pin their versions to make sure
|
|
@@ -37,12 +36,6 @@
|
|
# I want as little dependencies as practically possible.
|
|
default-features = false
|
|
|
|
-[dependencies.gettext-sys]
|
|
-version = "0.19.8"
|
|
-# Don't let the crate build its own copy of gettext; force it to use the one
|
|
-# built into glibc.
|
|
-features = [ "gettext-system" ]
|
|
-
|
|
[dev-dependencies]
|
|
tempfile = "3"
|
|
proptest = "0.7"
|
|
diff -uNr newsboat-2.17/rust/libnewsboat/src/cliargsparser.rs newsboat-2.17.mod/rust/libnewsboat/src/cliargsparser.rs
|
|
--- newsboat-2.17/rust/libnewsboat/src/cliargsparser.rs 2019-09-22 17:19:19.000000000 +0300
|
|
+++ newsboat-2.17.mod/rust/libnewsboat/src/cliargsparser.rs 2019-09-24 20:56:44.030818719 +0300
|
|
@@ -1,5 +1,4 @@
|
|
use clap::{App, Arg};
|
|
-use gettextrs::gettext;
|
|
use libc::{EXIT_FAILURE, EXIT_SUCCESS};
|
|
use std::path::PathBuf;
|
|
|
|
@@ -282,7 +281,7 @@
|
|
}
|
|
_ => {
|
|
args.display_msg = fmt!(
|
|
- &gettext("%s: %s: invalid loglevel value"),
|
|
+ "%s: %s: invalid loglevel value",
|
|
&opts[0],
|
|
log_level_str
|
|
);
|
|
diff -uNr newsboat-2.17/rust/libnewsboat/src/lib.rs newsboat-2.17.mod/rust/libnewsboat/src/lib.rs
|
|
--- newsboat-2.17/rust/libnewsboat/src/lib.rs 2019-09-22 17:19:19.000000000 +0300
|
|
+++ newsboat-2.17.mod/rust/libnewsboat/src/lib.rs 2019-09-24 20:56:44.030818719 +0300
|
|
@@ -11,7 +11,6 @@
|
|
#[macro_use]
|
|
extern crate proptest;
|
|
extern crate clap;
|
|
-extern crate gettextrs;
|
|
extern crate libc;
|
|
|
|
// This module must be declared before the others because it exports a `log!` macro that everyone
|