87 lines
2.2 KiB
Diff
87 lines
2.2 KiB
Diff
diff -u -r ../apt-1.4.7/CMakeLists.txt ./CMakeLists.txt
|
|
--- ../apt-1.4.7/CMakeLists.txt 2017-07-13 23:45:39.000000000 +0200
|
|
+++ ./CMakeLists.txt 2017-07-23 23:24:06.877483680 +0200
|
|
@@ -33,7 +33,6 @@
|
|
include(GNUInstallDirs)
|
|
include(TestBigEndian)
|
|
find_package(Threads)
|
|
-find_package(LFS REQUIRED)
|
|
find_package(Iconv REQUIRED)
|
|
|
|
find_package(Perl REQUIRED)
|
|
@@ -44,11 +43,6 @@
|
|
include_directories(${Intl_INCLUDE_DIRS})
|
|
endif()
|
|
|
|
-# Add large file support
|
|
-add_compile_options(${LFS_COMPILE_OPTIONS})
|
|
-add_definitions(${LFS_DEFINITIONS})
|
|
-link_libraries(${LFS_LIBRARIES})
|
|
-
|
|
# Set compiler flags
|
|
set(CMAKE_CXX_STANDARD 11)
|
|
set(CMAKE_CXX_STANDARD_REQUIRED ON)
|
|
@@ -69,13 +63,6 @@
|
|
add_optional_compile_options(Wsign-promo)
|
|
add_optional_compile_options(Wundef)
|
|
|
|
-# apt-ftparchive dependencies
|
|
-find_package(BerkeleyDB REQUIRED)
|
|
-if (BERKELEY_DB_FOUND)
|
|
- set(HAVE_BDB 1)
|
|
-endif()
|
|
-
|
|
-
|
|
# apt-transport-https dependencies
|
|
find_package(CURL REQUIRED)
|
|
if (CURL_FOUND)
|
|
@@ -89,21 +76,12 @@
|
|
endif()
|
|
|
|
|
|
-find_package(BZip2)
|
|
-if (BZIP2_FOUND)
|
|
- set(HAVE_BZ2 1)
|
|
-endif()
|
|
-
|
|
find_package(LZMA)
|
|
if (LZMA_FOUND)
|
|
set(HAVE_LZMA 1)
|
|
endif()
|
|
|
|
|
|
-find_package(LZ4)
|
|
-if (LZ4_FOUND)
|
|
- set(HAVE_LZ4 1)
|
|
-endif()
|
|
|
|
# Mount()ing and stat()ing and friends
|
|
check_symbol_exists(statfs sys/vfs.h HAVE_VFS_H)
|
|
@@ -180,10 +158,10 @@
|
|
message(STATUS "Found dpkg data dir: ${DPKG_DATADIR_CMD}")
|
|
set(DPKG_DATADIR "${DPKG_DATADIR_CMD}" CACHE PATH "dpkg data directory")
|
|
endif()
|
|
-if (NOT DEFINED COMMON_ARCH)
|
|
- execute_process(COMMAND dpkg-architecture -qDEB_HOST_ARCH
|
|
- OUTPUT_VARIABLE COMMON_ARCH OUTPUT_STRIP_TRAILING_WHITESPACE)
|
|
-endif()
|
|
+# if (NOT DEFINED COMMON_ARCH)
|
|
+# execute_process(COMMAND dpkg-architecture -qDEB_HOST_ARCH
|
|
+ #OUTPUT_VARIABLE COMMON_ARCH OUTPUT_STRIP_TRAILING_WHITESPACE)
|
|
+# endif()
|
|
if (NOT DEFINED ROOT_GROUP)
|
|
execute_process(COMMAND id -gn root
|
|
OUTPUT_VARIABLE ROOT_GROUP OUTPUT_STRIP_TRAILING_WHITESPACE)
|
|
@@ -211,11 +189,8 @@
|
|
add_subdirectory(apt-inst)
|
|
add_subdirectory(cmdline)
|
|
add_subdirectory(completions)
|
|
-add_subdirectory(doc)
|
|
add_subdirectory(dselect)
|
|
-add_subdirectory(ftparchive)
|
|
add_subdirectory(methods)
|
|
-add_subdirectory(test)
|
|
|
|
if (USE_NLS)
|
|
add_subdirectory(po)
|