21 lines
987 B
Diff
21 lines
987 B
Diff
--- elfutils-0.185/debuginfod/Makefile.am 2021-05-22 23:55:24.000000000 +0530
|
|
+++ elfutils-0.185-patch/debuginfod/Makefile.am 2021-08-29 00:51:31.449999941 +0530
|
|
@@ -42,7 +42,7 @@
|
|
|
|
if BUILD_STATIC
|
|
libasm = ../libasm/libasm.a
|
|
-libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl -lpthread
|
|
+libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl
|
|
libelf = ../libelf/libelf.a -lz
|
|
if DUMMY_LIBDEBUGINFOD
|
|
libdebuginfod = ./libdebuginfod.a
|
|
@@ -70,7 +70,7 @@
|
|
endif
|
|
|
|
debuginfod_SOURCES = debuginfod.cxx
|
|
-debuginfod_LDADD = $(libdw) $(libelf) $(libeu) $(libdebuginfod) $(argp_LDADD) $(fts_LIBS) $(libmicrohttpd_LIBS) $(sqlite3_LIBS) $(libarchive_LIBS) -lpthread -ldl
|
|
+debuginfod_LDADD = $(libdw) $(libelf) $(libeu) $(libdebuginfod) $(argp_LDADD) $(fts_LIBS) $(libmicrohttpd_LIBS) $(sqlite3_LIBS) $(libarchive_LIBS) -ldl
|
|
|
|
debuginfod_find_SOURCES = debuginfod-find.c
|
|
debuginfod_find_LDADD = $(libdw) $(libelf) $(libeu) $(libdebuginfod) $(argp_LDADD) $(fts_LIBS)
|