termux-packages/packages/cmake/Source-CMakeLists.txt.patch

13 lines
518 B
Diff

diff -u -r ../cmake-3.15.2/Source/CMakeLists.txt ./Source/CMakeLists.txt
--- ../cmake-3.15.2/Source/CMakeLists.txt 2019-08-07 16:58:29.000000000 +0000
+++ ./Source/CMakeLists.txt 2019-08-21 10:42:07.237355685 +0000
@@ -759,7 +759,7 @@
# GHS support
# Works only for windows and linux
-if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Linux")
+if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Linux" OR CMAKE_SYSTEM_NAME STREQUAL "Android")
set(SRCS ${SRCS}
cmGlobalGhsMultiGenerator.cxx
cmGlobalGhsMultiGenerator.h