termux-packages/packages/gsl/Makefile.in.patch
Fredrik Fornwall 59f0d218a6 Initial push
2015-06-13 01:03:31 +02:00

22 lines
875 B
Diff

Normally GSL wants an application to decide at link time which cblas implementation
should be used. This causes problems on Android without any benefit as no system
cblas implementation exist, so we link libgsql to libgslcblas.
See
https://www.gnu.org/software/gsl/manual/html_node/Linking-programs-with-the-library.html
diff -u -r ../gsl-1.16/Makefile.in ./Makefile.in
--- ../gsl-1.16/Makefile.in 2013-07-19 11:14:52.000000000 -0400
+++ ./Makefile.in 2015-01-02 02:20:40.304345796 -0500
@@ -84,8 +84,8 @@
POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
-@MINGW32_HOST_TRUE@am__append_1 = cblas/libgslcblas.la
-@MINGW32_HOST_TRUE@am__append_2 = -no-undefined
+am__append_1 = cblas/libgslcblas.la
+am__append_2 = -no-undefined
bin_PROGRAMS = gsl-randist$(EXEEXT) gsl-histogram$(EXEEXT)
subdir = .
DIST_COMMON = INSTALL NEWS README AUTHORS ChangeLog \