21 lines
689 B
Diff
21 lines
689 B
Diff
diff -u -r ../luv-1.30.1-1/CMakeLists.txt ./CMakeLists.txt
|
|
--- ../luv-1.30.1-1/CMakeLists.txt 2019-09-18 04:33:34.000000000 +0000
|
|
+++ ./CMakeLists.txt 2019-09-25 22:23:19.659091635 +0000
|
|
@@ -107,7 +107,6 @@
|
|
include_directories(${LUAJIT_INCLUDE_DIR})
|
|
link_directories(${LUAJIT_LIBRARIES})
|
|
else (USE_LUAJIT)
|
|
- find_package(Lua REQUIRED)
|
|
include_directories(${LUA_INCLUDE_DIR})
|
|
endif (USE_LUAJIT)
|
|
|
|
@@ -175,7 +174,7 @@
|
|
elseif("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
|
|
target_link_libraries(luv ${LIBUV_LIBRARIES} rt)
|
|
else()
|
|
- target_link_libraries(luv ${LIBUV_LIBRARIES})
|
|
+ target_link_libraries(luv m lua ${LIBUV_LIBRARIES})
|
|
endif()
|
|
|
|
if (NOT LUA)
|