45 lines
1.2 KiB
Diff
45 lines
1.2 KiB
Diff
@@ from https://sources.debian.org/patches/maildir-utils/1.6.9-1/mu4e-dont-bytecompile/
|
|
---
|
|
configure.ac | 18 ++++--------------
|
|
mu4e/Makefile.am | 2 +-
|
|
2 files changed, 5 insertions(+), 15 deletions(-)
|
|
|
|
--- a/mu4e/Makefile.am
|
|
+++ b/mu4e/Makefile.am
|
|
@@ -21,7 +21,7 @@ SUBDIRS=
|
|
info_TEXINFOS=mu4e.texi
|
|
mu4e_TEXINFOS=fdl.texi
|
|
|
|
-dist_lisp_LISP= \
|
|
+dist_lisp_DATA= \
|
|
mu4e-actions.el \
|
|
mu4e-compose.el \
|
|
mu4e-context.el \
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -85,20 +85,10 @@ AM_COND_IF(HAVE_MAKEINFO,[],[
|
|
AC_SUBST(MAKEINFO,[true])
|
|
])
|
|
|
|
-# we need emacs for byte-compiling mu4e
|
|
-build_mu4e=no
|
|
-AC_ARG_ENABLE([mu4e],
|
|
- AS_HELP_STRING([--disable-mu4e],[Disable building mu4e]))
|
|
-AS_IF([test "x$enable_mu4e" != "xno"], [
|
|
- AM_PATH_LISPDIR
|
|
- AS_IF([test "x$lispdir" != "xno"], [
|
|
- emacs_version="$($EMACS --version | head -1)"
|
|
- lispdir="${lispdir}/mu4e/"
|
|
- ])
|
|
- AS_CASE([$emacs_version],
|
|
- [*25.3*],[build_mu4e=yes],
|
|
- [*26*|*27*|*28*|*29*],[build_mu4e=yes],
|
|
- [AC_WARN([emacs is too old to build mu4e (need emacs >= 25.3)])])
|
|
+build_mu4e=yes
|
|
+AM_PATH_LISPDIR
|
|
+AS_IF([test "x$lispdir" != "xno"], [
|
|
+ lispdir="${lispdir}/mu4e/"
|
|
])
|
|
AM_CONDITIONAL(BUILD_MU4E, test "x$build_mu4e" = "xyes")
|
|
|