termux-packages/packages/coreutils/Makefile.in.patch

39 lines
1.3 KiB
Diff

Use man pages generated by help2man in the host build.
diff -u -r ../coreutils-8.24/Makefile.in ./Makefile.in
--- ../coreutils-8.24/Makefile.in 2015-07-03 17:23:13.000000000 -0400
+++ ./Makefile.in 2015-07-04 07:38:25.901795437 -0400
@@ -14242,31 +14242,7 @@
@SINGLE_BINARY_FALSE@man/yes.1: src/yes$(EXEEXT)
.x.1:
- $(AM_V_GEN)name=`echo $@ | sed 's|.*/||; s|\.1$$||'` || exit 1; \
- case $$name in \
- install) prog='ginstall'; argv=$$name;; \
- test) prog='['; argv='[';; \
- *) prog=$$name; argv=$$prog;; \
- esac; \
- rm -f $@ $@-t \
- && t=$*.td \
- && rm -rf $$t \
- && $(MKDIR_P) $$t \
- && (cd $$t && $(LN_S) '$(abs_top_builddir)/src/'$$prog$(EXEEXT) \
- $$argv$(EXEEXT)) \
- && $(run_help2man) \
- --source='$(PACKAGE_STRING)' \
- --include=$(srcdir)/man/$$name.x \
- --output=$$t/$$name.1 \
- --info-page='\(aq(coreutils) '$$name' invocation\(aq' \
- $$t/$$argv$(EXEEXT) \
- && sed \
- -e 's|$*\.td/||g' \
- -e '/For complete documentation/d' \
- $$t/$$name.1 > $@-t \
- && rm -rf $$t \
- && chmod a-w $@-t \
- && mv $@-t $@
+ cp $(top_srcdir)/../host-build/$@ $@
.PHONY: check-root
check-root:
$(MAKE) check TESTS='$(root_tests)' SUBDIRS=.