26 lines
1.2 KiB
Diff
26 lines
1.2 KiB
Diff
diff -u -r ../glib-2.60.2/meson.build ./meson.build
|
|
--- ../glib-2.60.2/meson.build 2019-05-03 13:43:28.000000000 +0000
|
|
+++ ./meson.build 2019-05-11 20:10:26.054269305 +0000
|
|
@@ -360,7 +360,6 @@
|
|
# https://wiki.gnome.org/Projects/GLib/CompilerRequirements#Function_pointer_conversions.
|
|
'-Wno-pedantic',
|
|
'-Werror=declaration-after-statement',
|
|
- '-Werror=format=2',
|
|
'-Werror=implicit-function-declaration',
|
|
'-Werror=init-self',
|
|
'-Werror=missing-include-dirs',
|
|
--- ./meson.build.orig 2019-06-11 00:18:20.480045589 +0000
|
|
+++ ./meson.build 2019-06-11 00:19:34.408583457 +0000
|
|
@@ -1780,9 +1780,8 @@
|
|
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
|
|
# implementations. This could be extended if issues are found in some platforms.
|
|
libintl_deps = []
|
|
-if cc.has_function('ngettext')
|
|
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
|
|
-else
|
|
+have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
|
|
+if host_system != 'android'
|
|
# First just find the bare library.
|
|
libintl = cc.find_library('intl', required : false)
|
|
# The bare library probably won't link without help if it's static.
|