53 lines
1.6 KiB
Diff
53 lines
1.6 KiB
Diff
diff -uNr lua-5.4.1/Makefile lua-5.4.1.mod/Makefile
|
|
--- lua-5.4.1/Makefile 2020-09-30 12:41:43.000000000 +0300
|
|
+++ lua-5.4.1.mod/Makefile 2020-11-10 21:37:18.308774443 +0200
|
|
@@ -4,17 +4,17 @@
|
|
# == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT =======================
|
|
|
|
# Your platform. See PLATS for possible values.
|
|
-PLAT= guess
|
|
+PLAT= linux
|
|
|
|
# Where to install. The installation starts in the src and doc directories,
|
|
# so take care if INSTALL_TOP is not an absolute path. See the local target.
|
|
# You may want to make INSTALL_LMOD and INSTALL_CMOD consistent with
|
|
# LUA_ROOT, LUA_LDIR, and LUA_CDIR in luaconf.h.
|
|
-INSTALL_TOP= /usr/local
|
|
+INSTALL_TOP= $(PREFIX)
|
|
INSTALL_BIN= $(INSTALL_TOP)/bin
|
|
INSTALL_INC= $(INSTALL_TOP)/include
|
|
INSTALL_LIB= $(INSTALL_TOP)/lib
|
|
-INSTALL_MAN= $(INSTALL_TOP)/man/man1
|
|
+INSTALL_MAN= $(INSTALL_TOP)/share/man/man1
|
|
INSTALL_LMOD= $(INSTALL_TOP)/share/lua/$V
|
|
INSTALL_CMOD= $(INSTALL_TOP)/lib/lua/$V
|
|
|
|
@@ -38,21 +38,21 @@
|
|
# Convenience platforms targets.
|
|
PLATS= guess aix bsd c89 freebsd generic linux linux-readline macosx mingw posix solaris
|
|
|
|
+# Lua version and release.
|
|
+V= 5.4
|
|
+R= $V.3
|
|
+
|
|
# What to install.
|
|
TO_BIN= lua luac
|
|
TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
|
|
-TO_LIB= liblua.a
|
|
+TO_LIB= liblua.a liblua.so.$(R)
|
|
TO_MAN= lua.1 luac.1
|
|
|
|
-# Lua version and release.
|
|
-V= 5.4
|
|
-R= $V.3
|
|
-
|
|
# Targets start here.
|
|
all: $(PLAT)
|
|
|
|
$(PLATS) help test clean:
|
|
- @cd src && $(MAKE) $@
|
|
+ @cd src && $(MAKE) $@ V=$(V) R=$(R)
|
|
|
|
install: dummy
|
|
cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
|