44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
From 85a3e5b4f65e5284e59dcdd90e92ea7d50ef6907 Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@openwide.fr>
|
|
Date: Sun, 8 Feb 2015 17:23:13 +0100
|
|
Subject: [PATCH] erts/emulator: reorder inclued headers paths
|
|
|
|
If the Perl Compatible Regular Expressions is installed on the
|
|
host and the path to the headers is added to the CFLAGS, the
|
|
pcre.h from the host is used instead of the one provided by
|
|
erlang.
|
|
|
|
Erlang use an old version of this file which is incompatible
|
|
with the upstream one.
|
|
|
|
Move INCLUDES before CFLAGS to use pcre.h from erlang.
|
|
|
|
http://autobuild.buildroot.net/results/cbd/cbd8b54eef535f19d7d400fd269af1b3571d6143/build-end.log
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
|
|
---
|
|
erts/emulator/Makefile.in | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/erts/emulator/Makefile.in b/erts/emulator/Makefile.in
|
|
index 7145824..d079487 100644
|
|
--- a/erts/emulator/Makefile.in
|
|
+++ b/erts/emulator/Makefile.in
|
|
@@ -678,11 +678,11 @@ else
|
|
# Usually the same as the default rule, but certain platforms (e.g. win32) mix
|
|
# different compilers
|
|
$(OBJDIR)/beam_emu.o: beam/beam_emu.c
|
|
- $(V_EMU_CC) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) $(INCLUDES) -c $< -o $@
|
|
+ $(V_EMU_CC) $(INCLUDES) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) -c $< -o $@
|
|
endif
|
|
|
|
$(OBJDIR)/%.o: beam/%.c
|
|
- $(V_CC) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) $(INCLUDES) -c $< -o $@
|
|
+ $(V_CC) $(INCLUDES) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) -c $< -o $@
|
|
|
|
$(OBJDIR)/%.o: $(TARGET)/%.c
|
|
$(V_CC) $(CFLAGS) $(INCLUDES) -Idrivers/common -c $< -o $@
|
|
--
|
|
1.9.3
|
|
|