termux-packages/packages/emscripten/llvm-project-libunwind-CMakeLists.txt.patch.diff
Jia Yuan Lo 49f4c2dbe1 emscripten: update some details
* upstream now use LLVM 15, update patches
* drop building libunwind until further notice
* patch binaryen CMakeLists.txt
* should be able to run tests now that python3 multiprocessing works
2022-03-08 04:52:59 +09:00

15 lines
700 B
Diff

diff -uNr llvm-project/libunwind/CMakeLists.txt llvm-project.mod/libunwind/CMakeLists.txt
--- llvm-project/libunwind/CMakeLists.txt 2022-02-24 01:38:33.000000000 +0800
+++ llvm-project.mod/libunwind/CMakeLists.txt 2022-02-26 20:33:34.373468611 +0800
@@ -222,6 +222,10 @@
add_compile_flags_if_supported(-Werror=return-type)
if (LIBUNWIND_ENABLE_CET)
+ if (NOT "libunwind" IN_LIST LLVM_ENABLE_RUNTIMES
+ AND "clang" IN_LIST LLVM_ENABLE_PROJECTS)
+ include_directories("${CMAKE_CURRENT_SOURCE_DIR}/../clang/lib/Headers")
+ endif()
add_compile_flags_if_supported(-fcf-protection=full)
add_compile_flags_if_supported(-mshstk)
if (NOT LIBUNWIND_SUPPORTS_FCF_PROTECTION_EQ_FULL_FLAG)