cefee4f432
* emscripten: update to 2.0.32 * emscripten: drop debianutils Upstream has replaced "which" usage with POSIX "command -v" * emscripten: subpackage third party test suite * emscripten: add detail run test suite instruction * emscripten: use TERMUX_PKG_RM_AFTER_INSTALL * emscripten: split patch to separate diff files * emscripten-llvm: switch to use LLD
15 lines
700 B
Diff
15 lines
700 B
Diff
diff -uNr llvm-project/libunwind/CMakeLists.txt llvm-project.mod/libunwind/CMakeLists.txt
|
|
--- llvm-project/libunwind/CMakeLists.txt 2021-10-20 02:24:04.000000000 +0800
|
|
+++ llvm-project.mod/libunwind/CMakeLists.txt 2021-10-29 10:02:54.163942494 +0800
|
|
@@ -194,6 +194,10 @@
|
|
add_compile_flags_if_supported(-Werror=return-type)
|
|
|
|
if (LIBUNWIND_ENABLE_CET)
|
|
+ if (NOT "libunwind" IN_LIST LLVM_ENABLE_RUNTIMES
|
|
+ AND "clang" IN_LIST LLVM_ENABLE_PROJECTS)
|
|
+ include_directories("${CMAKE_CURRENT_SOURCE_DIR}/../clang/lib/Headers")
|
|
+ endif()
|
|
add_compile_flags_if_supported(-fcf-protection=full)
|
|
add_compile_flags_if_supported(-mshstk)
|
|
if (NOT LIBUNWIND_SUPPORTS_FCF_PROTECTION_EQ_FULL_FLAG)
|