32 lines
1.3 KiB
Diff
32 lines
1.3 KiB
Diff
diff -u -r ../libvpx-1.6.1/build/make/configure.sh ./build/make/configure.sh
|
|
--- ../libvpx-1.6.1/build/make/configure.sh 2017-01-12 20:27:27.000000000 +0000
|
|
+++ ./build/make/configure.sh 2017-07-27 01:11:03.641678047 +0000
|
|
@@ -891,7 +891,6 @@
|
|
setup_gnu_toolchain
|
|
arch_int=${tgt_isa##armv}
|
|
arch_int=${arch_int%%te}
|
|
- check_add_asflags --defsym ARCHITECTURE=${arch_int}
|
|
tune_cflags="-mtune="
|
|
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
|
|
if [ -z "${float_abi}" ]; then
|
|
@@ -1021,7 +1020,6 @@
|
|
else
|
|
echo "Assuming standalone build with NDK toolchain."
|
|
echo "See build/make/Android.mk for details."
|
|
- check_add_ldflags -static
|
|
soft_enable unit_tests
|
|
fi
|
|
;;
|
|
diff -u -r ../libvpx-1.6.1/configure ./configure
|
|
--- ../libvpx-1.6.1/configure 2017-01-12 20:27:27.000000000 +0000
|
|
+++ ./configure 2017-07-27 01:09:43.590546540 +0000
|
|
@@ -500,7 +500,7 @@
|
|
# Supported platforms
|
|
;;
|
|
*)
|
|
- if enabled gnu; then
|
|
+ if enabled gnu || enabled android; then
|
|
echo "--enable-shared is only supported on ELF; assuming this is OK"
|
|
else
|
|
die "--enable-shared only supported on ELF, OS/2, and Darwin for now"
|