9d2c5ea8fb
ncmpcpp segfaults on android 9 because it picks up iconv in libc.so if we don't link against libandroid-support.so properly. This fixes https://github.com/termux/termux-packages/issues/3333.
12 lines
387 B
Diff
12 lines
387 B
Diff
--- ../configure.ac.orig 2019-04-13 16:42:43.319705874 +0000
|
|
+++ ./configure.ac 2019-04-13 16:42:50.146372491 +0000
|
|
@@ -78,7 +78,7 @@
|
|
AC_SUBST(BOOST_LOCALE_LDFLAGS)
|
|
AC_SUBST(BOOST_LOCALE_LIBS)
|
|
LDFLAGS="$LDFLAGS $BOOST_LOCALE_LDFLAGS"
|
|
-LIBS="$LIBS $BOOST_LOCALE_LIBS"
|
|
+LIBS="$LIBS $BOOST_LOCALE_LIBS -landroid-support"
|
|
|
|
BOOST_PROGRAM_OPTIONS
|
|
AC_SUBST(BOOST_PROGRAM_OPTIONS_LDFLAGS)
|