35aecce3a3
* add bvi package * add new package: cgdb * add gdb in cgdb's TERMUX_PKG_DEPENDS * add new package: redir * bvi package revision 1: fix column number issue with clang (gcc does not seem to have this issue) bvi (compiled with clang) incorrectly displayed only 12 bytes for each line on a 80-column terminal (instead of 16 bytes normally). command :set cm=## also had similar problems. I found the issue was caused by the following statements: sprintf(addr_form, "%%0%dllX ", AnzAdd); AnzAdd = sprintf(tmp, addr_form, block_begin); ('block_begin''s data type is off_t) gcc automatically typecasts 'block_begin' from off_t to loff_t, on the otherhand, clang takes address of 'block_begin' and uses it as loff_t thus writes some garbage value in 'tmp' string.
32 lines
849 B
Diff
32 lines
849 B
Diff
--- redir-2.2.1/Makefile 1999-12-26 12:51:55.000000000 -0800
|
|
+++ src/Makefile 2017-02-15 13:07:10.577481896 -0800
|
|
@@ -15,7 +15,8 @@
|
|
# if your system needs any additional libraries (solaris, for example,
|
|
# needs the ones commented out below), edit this line.
|
|
|
|
-EXTRA_LIBS = #-lnsl -lsocket
|
|
+#EXTRA_LIBS = #-lnsl -lsocket
|
|
+EXTRA_LIBS = -llog
|
|
|
|
# add additional compiler flags here. Some useful ones are:
|
|
#
|
|
@@ -27,7 +28,7 @@
|
|
### end of user configuration section
|
|
|
|
# redir requires gcc. if you're lucky, another compiler might work.
|
|
-CC = gcc
|
|
+#CC = gcc
|
|
|
|
# if your system lacks getopt_long, remove the comment from this line
|
|
OBJS = redir.o $(GETOPT_OBJS)
|
|
@@ -51,6 +52,9 @@
|
|
redir: ${OBJS}
|
|
${CC} ${LDFLAGS} -o redir ${OBJS} ${LIBS}
|
|
|
|
+install: all
|
|
+ install redir $(PREFIX)/bin
|
|
+ install redir.man $(PREFIX)/share/man/man1/redir.1
|
|
|
|
|
|
|