44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
diff --git a/src/meson.build b/src/meson.build
|
|
index ae8f387..359463c 100644
|
|
--- a/src/meson.build
|
|
+++ b/src/meson.build
|
|
@@ -55,23 +55,24 @@ if get_option('scanner')
|
|
install: true
|
|
)
|
|
|
|
- pkgconfig.generate(
|
|
- name: 'Wayland Scanner',
|
|
- description: 'Wayland scanner',
|
|
- version: meson.project_version(),
|
|
- variables: [
|
|
- 'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
|
|
- 'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name()),
|
|
- 'bindir=' + join_paths('${prefix}', get_option('bindir')),
|
|
- 'wayland_scanner=${bindir}/wayland-scanner'
|
|
- ],
|
|
- filebase: 'wayland-scanner'
|
|
- )
|
|
+ if not meson.is_cross_build()
|
|
+ pkgconfig.generate(
|
|
+ name: 'Wayland Scanner',
|
|
+ description: 'Wayland scanner',
|
|
+ version: meson.project_version(),
|
|
+ variables: [
|
|
+ 'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
|
|
+ 'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name()),
|
|
+ 'bindir=' + join_paths('${prefix}', get_option('bindir')),
|
|
+ 'wayland_scanner=${bindir}/wayland-scanner'
|
|
+ ],
|
|
+ filebase: 'wayland-scanner'
|
|
+ )
|
|
+ endif
|
|
endif
|
|
|
|
if meson.is_cross_build() or not get_option('scanner')
|
|
- scanner_dep = dependency('wayland-scanner', native: true, version: meson.project_version())
|
|
- wayland_scanner_for_build = find_program(scanner_dep.get_pkgconfig_variable('wayland_scanner'))
|
|
+ wayland_scanner_for_build = '/usr/bin/wayland-scanner'
|
|
else
|
|
wayland_scanner_for_build = wayland_scanner
|
|
endif
|