termux-packages/packages/ledger/CMakeLists.patch
Randy c1d58f98de
compile ledger with Python support (#7007)
* compile ledger with Python support

This adds a compile-time configuration option to compile ledger with Python 3 support and adds python to the list of dependencies. Not sure if the dependency should be written as `python` or `python3`. Any corrections welcome
2021-06-15 08:00:29 +02:00

14 lines
541 B
Diff

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 30d97cb9..341e782e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -335,7 +335,7 @@ if (USE_PYTHON)
$<TARGET_FILE:libledger> "${CMAKE_BINARY_DIR}/${_ledger_python_module_name}")
install(
FILES "${CMAKE_BINARY_DIR}/${_ledger_python_module_name}"
- DESTINATION ${Python_SITEARCH})
+ DESTINATION @TERMUX_PREFIX@/lib/python3.9/site-packages/)
else()
message(WARNING "Python_SITEARCH not set. Will not install python module.")
endif()