termux-packages/root-packages/frida-server/frida-python-src-meson.build.patch
Henrik Grimler f7e7c6db22
frida: add subpackages frida-python and frida-tools
Needs some more testing, and postinst scripts to install python dependencies.
2022-04-18 14:31:26 +05:30

18 lines
712 B
Diff

--- ../frida-python-src-meson.build.orig 2020-02-23 12:56:01.181265200 +0100
+++ ./frida-python/src/meson.build 2020-02-23 16:08:00.390756673 +0100
@@ -1,4 +1,4 @@
-extra_link_args = []
+extra_link_args = ['-L@TERMUX_PREFIX@/lib', '-lpython3.8']
if host_os_family == 'darwin'
extra_link_args += ['-Wl,-exported_symbol,_' + python_plugin_export_name]
elif host_os_family != 'windows'
@@ -9,7 +9,7 @@
name_prefix: '',
name_suffix: 'so',
c_args: frida_component_cflags,
- include_directories: include_directories(python_incdir),
+ include_directories: include_directories('@TERMUX_PREFIX@/include', python_incdir),
link_args: extra_link_args,
dependencies: [frida_core_dep],
install: true,