Removing searching for wayland-scanner.

This commit is contained in:
sergiotarxz 2022-05-13 19:41:07 +02:00
parent 655e9089fc
commit 02f1f95f1e
1 changed files with 17 additions and 3 deletions

View File

@ -1,13 +1,27 @@
diff --git a/hw/xwayland/meson.build b/hw/xwayland/meson.build
index e848daf0d..42e7b529b 100644
index e848daf0d..7af47d4a4 100644
--- a/hw/xwayland/meson.build
+++ b/hw/xwayland/meson.build
@@ -29,7 +29,7 @@ srcs = [
@@ -28,8 +28,7 @@ srcs = [
'../../mi/miinitext.h',
]
scanner_dep = dependency('wayland-scanner', native: true)
-scanner_dep = dependency('wayland-scanner', native: true)
-scanner = find_program(scanner_dep.get_pkgconfig_variable('wayland_scanner'))
+scanner = '/usr/bin/wayland-scanner'
protocols_dep = dependency('wayland-protocols', version: wayland_protocols_req)
protodir = protocols_dep.get_pkgconfig_variable('pkgdatadir')
@@ -48,11 +47,7 @@ client_header = generator(scanner,
arguments : ['client-header', '@INPUT@', '@OUTPUT@']
)
-if scanner_dep.version().version_compare('>= 1.14.91')
- scanner_argument = 'private-code'
-else
- scanner_argument = 'code'
-endif
+scanner_argument = 'private-code'
code = generator(scanner,
output : '@BASENAME@-protocol.c',