Adding scanner again and a patch to find the correct wayland-scanner

This commit is contained in:
sergiotarxz 2022-05-13 02:47:13 +02:00
parent ffe8d7909b
commit 96e8b00f72
2 changed files with 14 additions and 1 deletions

View File

@ -8,7 +8,7 @@ TERMUX_PKG_SRCURL=https://wayland.freedesktop.org/releases/wayland-${TERMUX_PKG_
TERMUX_PKG_SHA256=b8a034154c7059772e0fdbd27dbfcda6c732df29cae56a82274f6ec5d7cd8725
TERMUX_PKG_DEPENDS="libandroid-support, libffi, libxml2, libexpat"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-Dscanner=false
-Dscanner=true
-Dlibraries=true
-Ddocumentation=false
-Dtests=false

View File

@ -0,0 +1,13 @@
diff --git a/src/meson.build b/src/meson.build
index a601724..d82a6b3 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -75,7 +75,7 @@ endif
if meson.is_cross_build() or not get_option('scanner')
scanner_dep = dependency('wayland-scanner', native: true, version: meson.project_version())
- wayland_scanner_for_build = find_program(scanner_dep.get_variable(pkgconfig: 'wayland_scanner'))
+ wayland_scanner_for_build = '/usr/bin/wayland-scanner'
else
wayland_scanner_for_build = wayland_scanner
endif