Seems we need to depend on qt5-qtdeclarative and disable python bindings (though the latter could probably be fixed somehow). Error from python bindings was: CMake Error at /data/data/com.termux/files/usr/share/ECM/find-modules/FindPythonModuleGeneration.cmake:170 (message): The max python version in PythonModuleGeneration must be updated. Call Stack (most recent call first): src/CMakeLists.txt:63 (find_package)
12 lines
316 B
Diff
12 lines
316 B
Diff
--- ../src-CMakeLists.txt.orig 2021-10-15 17:34:25.460656823 +0000
|
|
+++ ./src/CMakeLists.txt 2021-10-15 17:34:39.275431640 +0000
|
|
@@ -60,8 +60,6 @@
|
|
REQUIRED_HEADERS KI18n_HEADERS
|
|
)
|
|
|
|
-find_package(PythonModuleGeneration)
|
|
-
|
|
if (PythonModuleGeneration_FOUND)
|
|
ecm_generate_python_binding(
|
|
TARGET KF5::I18n
|