36 lines
864 B
Diff
36 lines
864 B
Diff
commit fbb180464035f2dd573cbbe3aa722d5dec159ea2
|
|
Author: Mike Taves <mwtoews@gmail.com>
|
|
Date: Sat Nov 30 20:39:26 2019 +1300
|
|
|
|
Fix CMake build without tests
|
|
|
|
Fixes #1006
|
|
|
|
diff --git a/.gitignore b/.gitignore
|
|
index 1d28538b..57712f8b 100644
|
|
--- a/.gitignore
|
|
+++ b/.gitignore
|
|
@@ -70,4 +70,5 @@ authors.git
|
|
!/docker/**/Makefile
|
|
/.vs*
|
|
.idea/
|
|
+.project
|
|
out/
|
|
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
|
|
index 93653818..77c93ed6 100644
|
|
--- a/doc/CMakeLists.txt
|
|
+++ b/doc/CMakeLists.txt
|
|
@@ -13,9 +13,11 @@
|
|
add_executable(example example.cpp)
|
|
|
|
target_link_libraries(example PRIVATE geos)
|
|
-target_include_directories(test_geos_unit
|
|
+if(BUILD_TESTING)
|
|
+ target_include_directories(test_geos_unit
|
|
PRIVATE
|
|
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}>)
|
|
+endif()
|
|
|
|
option(BUILD_DOCUMENTATION "Build Doxygen documentation" OFF)
|
|
|